Results 1 to 2 of 2

Thread: Directory not writable

  1. #1

    Directory not writable


    I try to upload files with the PUT method. The API always returns the error (code 403) "Forbidden: root/users/[...] is not writable". When I ask the API for my permissions in that directory, it tells me that "readable" and "writable" are both true.

    I tried to upload via POST too, but same error. So until now I was never able to upload any file through the API.

    Anyone an idea about the reason for that?

    Thanks in advance,

  2. #2
    HiDrive Development
    Join Date
    Oct 2013
    This question was resolved: The directory was indeed not writable as, in this instance, the the user only granted read-only access in the authorization phase (scope: ro,user).

    When debugging permission issues, it is also important to realize that there are ACL permissions that relate to the user account vs. those that are granted to clients. For example, a user always has read/write access to his home directory but may choose not to grant your app more than read-only access. Similarly, the user’s access to /public may be restricted which means that she cannot grant your app access to that directory.

    To find out if your app has access to a specific path (and if not, why) three endpoints may need to be checked:

    1. Is the app authorized to read/write? Check effective permissions at GET /meta
    2. Does the user’s authorization restrict the app? Check refresh_token.scope at GET /app/me
    3. Do user-level ACLs permit access? Check GET /permission

    Items 2 and 3 are only relevant if you want to display a notification explaining to the user why the operation failed.
    Cornelius Bartke, STRATO HiDrive, Development

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts